Register today

System Requirements

Promap v2 is available on all modern browsers and operating systems, however please see below our recommended configuration..

Browsers:

  • Google Chrome v.70 and above
  • Firefox v.66
  • Edge v.17 and above
  • Safari v.12 and above

Operating Systems:

  • Windows 10
  • macOS 10.12 and above